Aprimorando

Erro composer update com PHP 7.3+

[ErrorException] "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?

Após instalar o PHP 7.3 o composer parou de funcionar e a única solução que encontrei até o momento foi deixar o PHP 7.2 também instalado para rodar o composer.

Por padrão o composer executa o comando php que está nas variáveis de ambiente.

Para verificar a sua versão utilize php -v.

Para rodar o composer com o PHP 7.2 ou inferior utilize:

php7.2 /usr/bin/composer update

Isto supondo que você tenha instalado o composer pelo apt, por isso utilizei o path padrão /usr/bin/composer.

 

:-)

  • ti , php , composer , composer update , php7.2 , php7.3 , linux
Aprimorando

Matheus

Autor

O homem é o microcosmo ou pequeno mundo, e conforme o dogma das analogias, tudo o que está no grande mundo se reproduz no pequeno.